Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2016-5637

Published: 15 July 2016

The restore_tqb_pixels function in libbpg 0.9.5 through 0.9.7 mishandles the transquant_bypass_enable_flag value, which allows remote attackers to execute arbitrary code or cause a denial of service (out-of-bounds write) via a crafted BPG image, related to a "type confusion" issue.

Notes

AuthorNote
ebarretto
This CVE doesn't have much information and it appears to be
a duplicate of CVE-2016-8710, so we are using the information
available on CVE-2016-8710.

Priority

Medium

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
chromium-browser
Launchpad, Ubuntu, Debian
artful Not vulnerable
(code not present)
bionic Not vulnerable
(code not present)
cosmic Not vulnerable
(code not present)
disco Not vulnerable
(code not present)
eoan Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
groovy Not vulnerable
(code not present)
hirsute Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)
noble Not vulnerable
(code not present)
precise Ignored

trusty Does not exist
(trusty was not-affected [code not present])
upstream Needs triage

wily Not vulnerable
(end of life)
xenial Not vulnerable
(code not present)
yakkety Not vulnerable
(code not present)
zesty Not vulnerable
(code not present)
ffmpeg
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(2.6)
cosmic Not vulnerable
(2.6)
disco Not vulnerable
(2.6)
eoan Not vulnerable
(2.6)
focal Not vulnerable
(2.6)
groovy Not vulnerable
(2.6)
hirsute Not vulnerable
(2.6)
impish Not vulnerable
(2.6)
jammy Not vulnerable
(2.6)
kinetic Not vulnerable
(2.6)
lunar Not vulnerable
(2.6)
mantic Not vulnerable
(2.6)
noble Not vulnerable
(2.6)
precise Does not exist

trusty Does not exist

upstream Needs triage

wily Ignored
(end of life)
xenial Not vulnerable
(2.6)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)
gst-libav1.0
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Needs triage

cosmic Ignored
(end of life)
disco Ignored
(end of life)
eoan Ignored
(end of life)
focal Needs triage

groovy Ignored
(end of life)
hirsute Ignored
(end of life)
impish Ignored
(end of life)
jammy Needs triage

kinetic Ignored
(end of life, was needs-triage)
lunar Ignored
(end of life, was needs-triage)
mantic Needs triage

noble Needs triage

precise Does not exist

trusty Does not exist
(trusty was needs-triage)
upstream Needs triage

wily Ignored
(end of life)
xenial Needs triage

yakkety Ignored
(end of life)
zesty Ignored
(end of life)
oxide-qt
Launchpad, Ubuntu, Debian
artful Not vulnerable
(code not present)
bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

precise Does not exist

trusty Does not exist
(trusty was not-affected [code not present])
upstream Needs triage

wily Not vulnerable
(end of life)
xenial Not vulnerable
(code not present)
yakkety Not vulnerable
(code not present)
zesty Not vulnerable
(code not present)
vlc
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(code not present)
cosmic Not vulnerable
(code not present)
disco Not vulnerable
(code not present)
eoan Not vulnerable
(code not present)
focal Not vulnerable
(code not present)
groovy Not vulnerable
(code not present)
hirsute Not vulnerable
(code not present)
impish Not vulnerable
(code not present)
jammy Not vulnerable
(code not present)
kinetic Not vulnerable
(code not present)
lunar Not vulnerable
(code not present)
mantic Not vulnerable
(code not present)
noble Not vulnerable
(code not present)
precise Ignored
(end of life)
trusty Does not exist

upstream Not vulnerable
(code not present)
wily Ignored
(end of life)
xenial Not vulnerable
(code not present)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H