CVE-2016-5239

Published: 15 March 2017

The gnuplot delegate functionality in ImageMagick before 6.9.4-0 and GraphicsMagick allows remote attackers to execute arbitrary commands via unspecified vectors.

From the Ubuntu security team

It was discovered that GraphicsMagick incorrectly handled certain image files. An attacker could possibly use this issue to cause a denial of service or other unspecified impact.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
graphicsmagick
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.24-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.24-1)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (1.3.23-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.3.18-1ubuntu3.1)
imagemagick
Launchpad, Ubuntu, Debian
Upstream
Released (8:6.8.9.9-5+deb8u2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (8:6.8.9.9-7ubuntu7)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (8:6.8.9.9-7ubuntu5.1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [8:6.7.7.10-6ubuntu3.1])
Patches:
Upstream: http://git.imagemagick.org/repos/ImageMagick/commit/70a2cf326ed32bedee144b961005c63846541a16