Your submission was sent successfully! Close

CVE-2016-5195

Published: 19 October 2016

Race condition in mm/gup.c in the Linux kernel 2.x through 4.x before 4.8.3 allows local users to gain privileges by leveraging incorrect handling of a copy-on-write (COW) feature to write to a read-only memory mapping, as exploited in the wild in October 2016, aka "Dirty COW."

From the Ubuntu security team

It was discovered that a race condition existed in the memory manager of the Linux kernel when handling copy-on-write breakage of private read-only memory mappings. A local attacker could use this to gain administrative privileges.

Priority

High

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
precise
Released (3.2.0-115.157)
trusty
Released (3.13.0-100.147)
upstream
Released (4.9~rc2)
xenial
Released (4.4.0-45.66)
yakkety
Released (4.8.0-26.28)
zesty Not vulnerable
(4.8.0-26.28)
linux-armadaxp
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was released [3.2.0-1677.104])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-aws
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Not vulnerable
(4.4.0-1002.2)
upstream
Released (4.9~rc2)
xenial Not vulnerable
(4.4.0-1001.10)
yakkety Does not exist

zesty Does not exist

linux-flo
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Ignored
(abandoned)
yakkety Ignored
(abandoned)
zesty Does not exist

linux-gke
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.9~rc2)
xenial Not vulnerable
(4.4.0-1003.3)
yakkety Does not exist

zesty Does not exist

linux-goldfish
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Ignored
(abandoned)
yakkety Ignored
(abandoned)
zesty Ignored
(abandoned)
linux-grouper
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.9~rc2)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
yakkety Does not exist

zesty Does not exist

linux-hwe-edge
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.9~rc2)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
yakkety Does not exist

zesty Does not exist

linux-linaro-omap
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [abandoned])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-linaro-shared
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [abandoned])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-linaro-vexpress
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [abandoned])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-quantal
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [end-of-life])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-raring
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [end-of-life])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-saucy
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [end-of-life])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-trusty
Launchpad, Ubuntu, Debian
precise
Released (3.13.0-100.147~precise1)
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-utopic
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-vivid
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was released [3.19.0-73.81~14.04.1])
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-wily
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored [out of standard support])
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
precise Does not exist

trusty
Released (4.4.0-45.66~14.04.1)
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-maguro
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-mako
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Ignored
(abandoned)
yakkety Ignored
(abandoned)
zesty Does not exist

linux-manta
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist
(trusty was ignored)
upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-qcm-msm
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was ignored [abandoned])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist

linux-raspi2
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.9~rc2)
xenial
Released (4.4.0-1029.36)
yakkety
Released (4.8.0-1018.21)
zesty Not vulnerable
(4.8.0-1017.20)
linux-snapdragon
Launchpad, Ubuntu, Debian
precise Does not exist

trusty Does not exist

upstream
Released (4.9~rc2)
xenial
Released (4.4.0-1032.36)
yakkety
Released (4.4.0-1032.36)
zesty Not vulnerable
(4.4.0-1032.36)
linux-ti-omap4
Launchpad, Ubuntu, Debian
precise Does not exist
(precise was released [3.2.0-1493.120])
trusty Does not exist

upstream
Released (4.9~rc2)
xenial Does not exist

yakkety Does not exist

zesty Does not exist