CVE-2016-5040

Published: 17 February 2017

libdwarf before 20160923 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a large length value in a compilation unit header.

Priority

Unknown

CVSS 3 base score: 7.5

Status

Package Release Status
dwarfutils
Launchpad, Ubuntu, Debian
Upstream
Released (20160507-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(20160507-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(20160507-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(20160507-1)
Ubuntu 16.04 LTS (Xenial Xerus) Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist
(precise was needs-triage)
Patches:
Upstream: https://sourceforge.net/p/libdwarf/code/ci/98a3da1e8237fe0d45b67ef77f3fa5ed9ff0215f/