Your submission was sent successfully! Close

CVE-2016-4429

Published: 10 June 2016

Stack-based buffer overflow in the clntudp_call function in sunrpc/clnt_udp.c in the GNU C Library (aka glibc or libc6) allows remote servers to cause a denial of service (crash) or possibly unspecified other impact via a flood of crafted ICMP and UDP packets.

From the Ubuntu security team

Aldy Hernandez discovered an unbounded stack allocation in the sunrpc implementation in the GNU C Library. An attacker could use this to cause a denial of service.

Priority

Low

CVSS 3 base score: 5.9

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

precise
Released (2.15-0ubuntu10.16)
trusty
Released (2.19-0ubuntu6.10)
upstream Needs triage

wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist

glibc
Launchpad, Ubuntu, Debian
artful Not vulnerable
(2.24-0ubuntu1)
bionic Not vulnerable
(2.24-0ubuntu1)
eoan Not vulnerable
(2.24-0ubuntu1)
focal Not vulnerable
(2.24-0ubuntu1)
groovy Not vulnerable
(2.24-0ubuntu1)
hirsute Not vulnerable
(2.24-0ubuntu1)
impish Not vulnerable
(2.24-0ubuntu1)
jammy Not vulnerable
(2.24-0ubuntu1)
precise Does not exist

trusty Does not exist

upstream Needs triage

wily Ignored
(reached end-of-life)
xenial
Released (2.23-0ubuntu6)
yakkety Not vulnerable
(2.24-0ubuntu1)
zesty Not vulnerable
(2.24-0ubuntu1)
Patches:
upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=bc779a1a5b3035133024b21e2f339fe4219fb11c (trunk)
upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=bdce95930e1d9a7d013d1ba78740243491262879 (2.23)
libtirpc
Launchpad, Ubuntu, Debian
artful Not vulnerable
(0.2.5-1.1)
bionic Not vulnerable
(0.2.5-1.1)
eoan Not vulnerable
(0.2.5-1.1)
focal Not vulnerable
(0.2.5-1.1)
groovy Not vulnerable
(0.2.5-1.1)
hirsute Not vulnerable
(0.2.5-1.1)
impish Not vulnerable
(0.2.5-1.1)
jammy Not vulnerable
(0.2.5-1.1)
precise
Released (0.2.2-5ubuntu0.1)
trusty
Released (0.2.2-5ubuntu2.1)
upstream
Released (0.2.5-1.1)
wily Ignored
(reached end-of-life)
xenial
Released (0.2.5-1ubuntu0.1)
yakkety Ignored
(reached end-of-life)
zesty Not vulnerable
(0.2.5-1.1)
ntirpc
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(code not present)
eoan Ignored
(reached end-of-life)
focal Not vulnerable
(code not present)
groovy Ignored
(reached end-of-life)
hirsute Ignored
(reached end-of-life)
impish Ignored
(reached end-of-life)
jammy Not vulnerable
(code not present)
precise Does not exist

trusty Does not exist

upstream Needs triage

xenial Ignored
(end of standard support, was needs-triage)