CVE-2016-4428

Published: 12 July 2016

Cross-site scripting (XSS) vulnerability in OpenStack Dashboard (Horizon) 8.0.1 and earlier and 9.0.0 through 9.0.1 allows remote authenticated users to inject arbitrary web script or HTML by injecting an AngularJS template in a dashboard form.

Priority

Medium

CVSS 3 base score: 5.4

Status

Package Release Status
horizon
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:9.1.2-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1:2014.1.5-0ubuntu2.1])
Patches:
Upstream: https://review.openstack.org/#/c/329998/ (master)
Upstream: https://review.openstack.org/#/c/329997/ (liberty)
Vendor: https://anonscm.debian.org/cgit/openstack/services/horizon.git/commit/?h=debian/icehouse (icehouse)