Your submission was sent successfully! Close

CVE-2016-4354

Published: 29 April 2016

ber-decoder.c in Libksba before 1.3.3 uses an incorrect integer data type, which allows remote attackers to cause a denial of service (crash) via crafted BER data, which leads to a buffer overflow.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
libksba
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.3.0-3ubuntu0.14.04.2])
Patches:
Upstream: http://git.gnupg.org/cgi-bin/gitweb.cgi?p=libksba.git;a=commit;h=aea7b6032865740478ca4b706850a5217f1c3887