CVE-2016-4342

Published: 29 April 2016

ext/phar/phar_object.c in PHP before 5.5.32, 5.6.x before 5.6.18, and 7.x before 7.0.3 mishandles zero-length uncompressed data, which allows remote attackers to cause a denial of service (heap memory corruption) or possibly have unspecified other impact via a crafted (1) TAR, (2) ZIP, or (3) PHAR archive.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.6.18+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.5.9+dfsg-1ubuntu4.17)
Patches:
Upstream: https://git.php.net/?p=php-src.git;a=commit;h=13ad4d3e971807f9a58ab5933182907dc2958539
php7.0
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.3-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7.0.4-7ubuntu2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: https://git.php.net/?p=php-src.git;a=commit;h=13ad4d3e971807f9a58ab5933182907dc2958539