Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2016-3981

Published: 13 April 2016

Heap-based buffer overflow in the bmp_read_rows function in pngxrbmp.c in OptiPNG before 0.7.6 allows remote attackers to cause a denial of service (out-of-bounds read or write access and crash) or possibly execute arbitrary code via a crafted image file.

Notes

AuthorNote
tyhicks
verified that 14.04 through 15.10 are affected via valgrind and
the reproducer from bugs.fi

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
optipng
Launchpad, Ubuntu, Debian
upstream
Released (0.7.6-1)
precise
Released (0.6.4-1ubuntu0.12.04.1)
trusty Does not exist
(trusty was released [0.6.4-1ubuntu0.14.04.1])
wily
Released (0.7.5-1ubuntu0.1)