CVE-2016-3630

Published: 13 April 2016

The binary delta decoder in Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a (1) clone, (2) push, or (3) pull command, related to (a) a list sizing rounding error and (b) short records.

From the Ubuntu security team

It was discovered that Mercurial incorrectly handled delta decoding. An attacker could possibly use this issue to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
mercurial
Launchpad, Ubuntu, Debian
Upstream
Released (3.7.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.7.3-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.7.3-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.8.2-1ubuntu1.4)