CVE-2016-3125

Published: 05 April 2016

The mod_tls module in ProFTPD before 1.3.5b and 1.3.6 before 1.3.6rc2 does not properly handle the TLSDHParamFile directive, which might cause a weaker than intended Diffie-Hellman (DH) key to be used and consequently allow attackers to have unspecified impact via unknown vectors.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
proftpd-dfsg
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.5b / 1.3.6rc2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(1.3.5b-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(1.3.5b-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(1.3.5b-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1.3.5b-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)