CVE-2016-3105

Published: 09 May 2016

The convert extension in Mercurial before 3.8 might allow context-dependent attackers to execute arbitrary code via a crafted git repository name.

From the Ubuntu security team

It was discovered that Mercurial incorrectly handled git repository name. An attacker could possibly use this issue to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
mercurial
Launchpad, Ubuntu, Debian
Upstream
Released (3.8.1-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.9.1-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (3.7.3-1ubuntu1.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.8.2-1ubuntu1.4)