CVE-2016-3068

Published: 13 April 2016

Mercurial before 3.7.3 allows remote attackers to execute arbitrary code via a crafted git ext:: URL when cloning a subrepository.

From the Ubuntu security team

It was discovered that Mercurial incorrectly handled git ext:: URL. An attacker could possibly use this issue to execute arbitrary code.

Priority

Medium

CVSS 3 base score: 8.8

Status

Package Release Status
mercurial
Launchpad, Ubuntu, Debian
Upstream
Released (3.7.3-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.7.3-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.7.3-1ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.8.2-1ubuntu1.4)