CVE-2016-2533

Published: 13 April 2016

Buffer overflow in the ImagingPcdDecode function in PcdDecode.c in Pillow before 3.1.1 and Python Imaging Library (PIL) 1.1.7 and earlier allows remote attackers to cause a denial of service (crash) via a crafted PhotoCD file.

Priority

Medium

CVSS 3 base score: 6.5

Status

Package Release Status
pillow
Launchpad, Ubuntu, Debian
Upstream
Released (3.1.1-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.1.1-1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.3.0-1ubuntu3.2)
Patches:
Upstream: https://github.com/python-pillow/Pillow/commit/ae453aa18b66af54e7ff716f4ccb33adca60afd4
python-imaging
Launchpad, Ubuntu, Debian
Upstream
Released (1.1.7-4+deb7u2)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist