Your submission was sent successfully! Close

CVE-2016-2148

Published: 09 February 2017

Heap-based buffer overflow in the DHCP client (udhcpc) in BusyBox before 1.25.0 allows remote attackers to have unspecified impact via vectors involving OPTION_6RD parsing.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
busybox
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.27.2-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:1.27.2-1ubuntu3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:1.22.0-15ubuntu1.4)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:1.21.0-1ubuntu1.4)
Patches:
Upstream: https://git.busybox.net/busybox/commit/?id=352f79acbd759c14399e39baef21fc4ffe180ac2
Binaries built from this source package are in Universe and so are supported by the community.