Your submission was sent successfully! Close

CVE-2016-2145

Published: 15 April 2016

The am_read_post_data function in mod_auth_mellon before 0.11.1 does not check if the ap_get_client_block function returns an error, which allows remote attackers to cause a denial of service (segmentation fault and process crash) via a crafted POST data.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
libapache2-mod-auth-mellon
Launchpad, Ubuntu, Debian
Upstream
Released (0.12.0-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.12.0-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.12.0-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://github.com/UNINETT/mod_auth_mellon/commit/ccb7dc35b941667122e02d5e81a52e2e4718ccee