CVE-2016-2074

Published: 28 March 2016

Buffer overflow in lib/flow.c in ovs-vswitchd in Open vSwitch 2.2.x and 2.3.x before 2.3.3 and 2.4.x before 2.4.1 allows remote attackers to execute arbitrary code via crafted MPLS packets, as demonstrated by a long string in an ovs-appctl command.

Priority

Low

CVSS 3 base score: 9.8

Status

Package Release Status
openvswitch
Launchpad, Ubuntu, Debian
Upstream
Released (2.5)
Ubuntu 16.04 LTS (Xenial Xerus) Not vulnerable
(2.5.0-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [2.0.2-0ubuntu0.14.04.3])