CVE-2016-2052

Published: 25 January 2016

Multiple unspecified vulnerabilities in HarfBuzz before 1.0.6, as used in Google Chrome before 48.0.2564.82, allow attackers to cause a denial of service or possibly have other impact via crafted data, as demonstrated by a buffer over-read resulting from an inverted length check in hb-ot-font.cc, a different issue than CVE-2015-8947.

Priority

Medium

CVSS 3 base score: 7.6

Status

Package Release Status
chromium-browser
Launchpad, Ubuntu, Debian
Upstream
Released (48.0.2564.82)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (48.0.2564.82-0ubuntu1.1222)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [48.0.2564.116-0ubuntu0.14.04.1.1111])
harfbuzz
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.6)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.1-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: https://cgit.freedesktop.org/harfbuzz/commit/?id=63ef0b41dc48d6112d1918c1b1de9de8ea90adb5
oxide-qt
Launchpad, Ubuntu, Debian
Upstream
Released (1.12.5)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.12.5-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.12.5-0ubuntu0.14.04.1])