CVE-2016-1903

Published: 19 January 2016

The gdImageRotateInterpolated function in ext/gd/libgd/gd_interpolation.c in PHP before 5.5.31, 5.6.x before 5.6.17, and 7.x before 7.0.2 allows remote attackers to obtain sensitive information or cause a denial of service (out-of-bounds read and application crash) via a large bgd_color argument to the imagerotate function.

Priority

Low

CVSS 3 base score: 9.1

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(code not present)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.6.17+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.5.9+dfsg-1ubuntu4.16)
Patches:
Upstream: https://github.com/php/php-src/commit/4bb422343f29f06b7081323844d9b52e1a71e4a5
Upstream: https://github.com/php/php-src/commit/2baeb167a08b0186a885208bdc8b5871f1681dc8
Upstream: https://github.com/php/php-src/commit/aa8d3a8cc612ba87c0497275f58a2317a90fb1c4
php7.0
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.2-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7.0.2-1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
mdeslaur
php uses the system libgd2, patches added to php packages have
no effect.
introduced by https://github.com/php/php-src/commit/07e52857b5f7a65c1552628e14a8a6aeeea24508
in php. Looks like a php-specific issue, not in libgd2.

References

Bugs