CVE-2016-1833

Published: 20 May 2016

The htmlCurrentChar function in libxml2 before 2.9.4, as used in Apple iOS before 9.3.2, OS X before 10.11.5, tvOS before 9.2.1, and watchOS before 2.2.1, allows remote attackers to cause a denial of service (heap-based buffer over-read) via a crafted XML document.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
libxml2
Launchpad, Ubuntu, Debian
Upstream
Released (2.9.4)
Ubuntu 16.04 LTS (Xenial Xerus)
Released (2.9.3+dfsg1-1ubuntu0.1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.9.1+dfsg1-3ubuntu4.8)
Ubuntu 12.04 ESM (Precise Pangolin)
Released (2.7.8.dfsg-5.1ubuntu4.15)
Patches:
Upstream: https://git.gnome.org/browse/libxml2/commit/?id=ff76eb28c75451bc56e3b93f44dac155ca29e7f5 (bp)
Upstream: https://git.gnome.org/browse/libxml2/commit/?id=fdfeecc1b73b0318466f0d61f0b8881ed9d92dd2 (bp)
Upstream: https://git.gnome.org/browse/libxml2/commit/?id=0bcd05c5cd83dec3406c8f68b769b1d610c72f76