CVE-2016-1550

Published: 29 April 2016

An exploitable vulnerability exists in the message authentication functionality of libntp in ntp 4.2.8p4 and NTPSec a5fb34b9cc89b92a8fef2f459004865c93bb7f92. An attacker can send a series of crafted messages to attempt to recover the message digest key.

Priority

Medium

CVSS 3 base score: 5.3

Status

Package Release Status
ntp
Launchpad, Ubuntu, Debian
Upstream
Released (1:4.2.8p7+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1:4.2.8p4+dfsg-3ubuntu5.3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:4.2.6.p5+dfsg-3ubuntu2.14.04.10)
Patches:
Upstream: http://bk1.ntp.org/ntp-stable/?PAGE=patch&REV=566bf5d3dZ5HASyXGnVlxig-qUuvqw
Vendor: http://pkgs.fedoraproject.org/cgit/rpms/ntp.git/tree/ntp-4.2.6p5-cve-2016-1550.patch