CVE-2016-1249

Published: 17 February 2017

The DBD::mysql module before 4.039 for Perl, when using server-side prepared statement support, allows attackers to cause a denial of service (out-of-bounds read) via vectors involving an unaligned number of placeholders in WHERE condition and output fields in SELECT expression.

Priority

Low

CVSS 3 base score: 5.9

Status

Package Release Status
libdbd-mysql-perl
Launchpad, Ubuntu, Debian
Upstream
Released (4.039-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(4.039-1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(4.039-1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(4.039-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(4.039-1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Needs triage

Patches:
Upstream: https://github.com/perl5-dbi/DBD-mysql/commit/793b72b1a0baa5070adacaac0e12fd995a6fbabe