Your submission was sent successfully! Close

CVE-2016-10905

Published: 18 August 2019

An issue was discovered in fs/gfs2/rgrp.c in the Linux kernel before 4.8. A use-after-free is caused by the functions gfs2_clear_rgrpd and read_rindex_entry.

From the Ubuntu security team

It was discovered that a race condition existed in the GFS2 file system in the Linux kernel. A local attacker could possibly use this to cause a denial of service (system crash).

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.13.0-16.19)
disco Not vulnerable
(4.18.0-10.11)
precise Ignored
(was needs-triage ESM criteria)
trusty Ignored
(was needs-triage ESM criteria)
upstream
Released (4.8~rc1)
xenial
Released (4.4.0-165.193)
linux-aws
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
disco Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Ignored
(was needs-triage ESM criteria)
upstream
Released (4.8~rc1)
xenial
Released (4.4.0-1095.106)
linux-aws-hwe
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.15.0-1030.31~16.04.1)
linux-azure
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Ignored
(was needs-triage ESM criteria)
upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.11.0-1009.9)
linux-azure-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.11.0-1009.9)
linux-gcp
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
disco Not vulnerable
(4.18.0-1002.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.10.0-1004.4)
linux-gcp-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1001.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Does not exist

linux-gke-4.15
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1030.32)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Does not exist

linux-gke-5.0
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-1011.11~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Does not exist

linux-hwe
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.18.0-13.14~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(5.0.0-15.16~18.04.1)
disco Does not exist

precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.8.0-36.36~16.04.1)
linux-kvm
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.2)
disco Not vulnerable
(4.18.0-1003.3)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial
Released (4.4.0-1059.66)
linux-lts-trusty
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Ignored
(was needs-triage ESM criteria)
trusty Does not exist

upstream
Released (4.8~rc1)
xenial Does not exist

linux-lts-xenial
Launchpad, Ubuntu, Debian
bionic Does not exist

disco Does not exist

precise Does not exist

trusty Ignored
(was needs-triage ESM criteria)
upstream
Released (4.8~rc1)
xenial Does not exist

linux-oem
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1002.3)
disco Not vulnerable
(4.15.0-1021.24)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Ignored
(was needs-triage now end-of-life)
linux-oracle
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.15.0-1007.9)
disco Not vulnerable
(4.15.0-1007.9)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial Not vulnerable
(4.15.0-1007.9~16.04.1)
linux-raspi2
Launchpad, Ubuntu, Debian
bionic Not vulnerable
(4.13.0-1005.5)
disco Not vulnerable
(4.18.0-1005.7)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial
Released (4.4.0-1123.132)
linux-snapdragon
Launchpad, Ubuntu, Debian
bionic
Released (4.15.0-1053.57)
disco Not vulnerable
(5.0.0-1010.10)
precise Does not exist

trusty Does not exist

upstream
Released (4.8~rc1)
xenial
Released (4.4.0-1127.135)