Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2015-9541

Published: 24 January 2020

Qt through 5.14 allows an exponential XML entity expansion attack via a crafted SVG document that is mishandled in QXmlStreamReader, a related issue to CVE-2003-1564.

Priority

Low

Cvss 3 Severity Score

7.5

Score breakdown

Status

Package Release Status
phantomjs
Launchpad, Ubuntu, Debian
bionic Needed

eoan Ignored
(end of life)
focal Needed

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

trusty Does not exist

upstream Needs triage

xenial Needed

pyside
Launchpad, Ubuntu, Debian
bionic Needed

eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

trusty Needed

upstream Needs triage

xenial Needed

pyside2
ROS ESM
bionic Does not exist

eoan Ignored
(end of life)
focal Needed

groovy Ignored
(end of life)
hirsute Ignored
(end of life)
impish Ignored
(end of life)
jammy Needed

kinetic Ignored
(end of life, was needed)
lunar Ignored
(end of life, was needed)
mantic Needed

trusty Does not exist

upstream Needs triage

xenial Needs triage

qt4-x11
Launchpad, Ubuntu, Debian
bionic Needed

eoan Ignored
(end of life)
focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

trusty Needed

upstream Needs triage

xenial Needed

qtbase-opensource-src
Launchpad, Ubuntu, Debian
bionic Needed

eoan Ignored
(end of life)
focal Not vulnerable
(5.12.5+dfsg-9build1)
groovy Not vulnerable
(5.12.5+dfsg-9build1)
hirsute Not vulnerable
(5.12.5+dfsg-9build1)
impish Not vulnerable
(5.12.5+dfsg-9build1)
jammy Not vulnerable
(5.12.5+dfsg-9build1)
kinetic Not vulnerable
(5.12.5+dfsg-9build1)
lunar Not vulnerable
(5.12.5+dfsg-9build1)
mantic Not vulnerable
(5.12.5+dfsg-9build1)
trusty Does not exist

upstream Needs triage

xenial Needed

Patches:
upstream: https://code.qt.io/cgit/qt/qtbase.git/commit/?id=fd4be84d23a0db4186cb42e736a9de3af722c7f7
upstream: https://code.qt.io/cgit/qt/qtbase.git/commit/?id=f432c08882ffebe5074ea28de871559a98a4d094

Severity score breakdown

Parameter Value
Base score 7.5
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality None
Integrity impact None
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H