CVE-2015-9101

Published: 25 June 2017

The fill_buffer_resample function in util.c in libmp3lame.a in LAME 3.98.4, 3.98.2, 3.98, 3.99, 3.99.1, 3.99.2, 3.99.3, 3.99.4 and 3.99.5 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted audio file.

From the Ubuntu security team

It was discovered that LAME incorrectly handled certain audio files. A remote attacker could possibly use this issue to cause a denial of service.

Priority

Medium

CVSS 3 base score: 5.5

Status

Package Release Status
lame
Launchpad, Ubuntu, Debian
Upstream
Released (3.99.5+repack1-6)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.99.5+repack1-9build1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.99.5+repack1-9build1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.99.5+repack1-9build1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.99.5+repack1-9build1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.99.5+repack1-9build1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Needed