Your submission was sent successfully! Close

CVE-2015-8994

Published: 02 March 2017

An issue was discovered in PHP 5.x and 7.x, when the configuration uses apache2handler/mod_php or php-fpm with OpCache enabled. With 5.x after 5.6.28 or 7.x after 7.0.13, the issue is resolved in a non-default configuration with the opcache.validate_permission=1 setting. The vulnerability details are as follows. In PHP SAPIs where PHP interpreters share a common parent process, Zend OpCache creates a shared memory object owned by the common parent during initialization. Child PHP processes inherit the SHM descriptor, using it to cache and retrieve compiled script bytecode ("opcode" in PHP jargon). Cache keys vary depending on configuration, but filename is a central key component, and compiled opcode can generally be run if a script's filename is known or can be guessed. Many common shared-hosting configurations change EUID in child processes to enforce privilege separation among hosted users (for example using mod_ruid2 for the Apache HTTP Server, or php-fpm user settings). In these scenarios, the default Zend OpCache behavior defeats script file permissions by sharing a single SHM cache among all child PHP processes. PHP scripts often contain sensitive information: Think of CMS configurations where reading or running another user's script usually means gaining privileges to the CMS database.

Priority

Low

CVSS 3 base score: 7.5

Status

Package Release Status
php5
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr)
Released (5.5.9+dfsg-1ubuntu4.22)
Patches:
Upstream: https://github.com/php/php-src/commit/ecba563f2fa1e027ea91b9ee0d50611273852995
Upstream: https://github.com/php/php-src/commit/8202b970777b84d57c590b78f9b6572ef0e0c205
Upstream: https://github.com/php/php-src/commit/9849c97b1bdfd7f0a7c499cad4cf601ebd68cc22
php7.0
Launchpad, Ubuntu, Debian
Upstream
Released (7.0.14-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(7.0.15-0ubuntu0.16.04.2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Patches:
Upstream: http://git.php.net/?p=php-src.git;a=commit;h=ecba563f2fa1e027ea91b9ee0d50611273852995
php7.1
Launchpad, Ubuntu, Debian
Upstream
Released (7.1.1-1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Notes

AuthorNote
sbeattie
PEAR issues should go against php-pear as of xenial
tyhicks
PHP7 < 7.0.14 and PHP5 < 5.6.29 are affected

References

Bugs