Your submission was sent successfully! Close

CVE-2015-8966

Published: 08 December 2016

arch/arm/kernel/sys_oabi-compat.c in the Linux kernel before 4.4 allows local users to gain privileges via a crafted (1) F_OFD_GETLK, (2) F_OFD_SETLK, or (3) F_OFD_SETLKW command in an fcntl64 system call.

From the Ubuntu security team

It was discovered that the fcntl64() system call in the Linux kernel did not properly set memory limits when returning on 32-bit ARM processors. A local attacker could use this to gain administrative privileges.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by 76cc404bfdc0d419c720de4daaf2584542734f42
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc8)

Notes

AuthorNote
ratliff
the fix commit is dated Dec. 2015
jdstrand
android kernels (flo, goldfish, grouper, maguro, mako and manta) are
not supported on the Ubuntu Touch 14.10 and earlier preview kernels
linux-lts-saucy no longer receives official support
linux-lts-quantal no longer receives official support
sbeattie
this was probably introduced with the Open File Descriptor
Locks patches in the 3.15 kernel, likely 5d50ffd7.

References