Your submission was sent successfully! Close

CVE-2015-8962

Published: 16 November 2016

Double free vulnerability in the sg_common_write function in drivers/scsi/sg.c in the Linux kernel before 4.4 allows local users to gain privileges or cause a denial of service (memory corruption and system crash) by detaching a device during an SG_IO ioctl call.

From the Ubuntu security team

It was discovered that the SCSI generic (sg) driver in the Linux kernel contained a double-free vulnerability. A local attacker could use this to cause a denial of service (system crash).

Priority

Medium

CVSS 3 base score: 7.3

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
Patches:
Introduced by 1da177e4c3f41524e886b7f1b8a0c1fc7321cac2
Fixed by f3951a3709ff50990bf3e188c27d346792103432
linux-armadaxp
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-aws
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-azure
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-euclid
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-flo
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-gcp
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-gke
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-goldfish
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-grouper
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-hwe
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-hwe-edge
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-kvm
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-linaro-omap
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-linaro-shared
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-quantal
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-lts-raring
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-saucy
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
This package is not directly supported by the Ubuntu Security Team
linux-lts-trusty
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-utopic
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-vivid
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-wily
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-lts-xenial
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-maguro
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-mako
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-manta
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-oem
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-qcm-msm
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-raspi2
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-snapdragon
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)
linux-ti-omap4
Launchpad, Ubuntu, Debian
Upstream
Released (4.4~rc1)