CVE-2015-8868

Published: 31 December 2015

Heap-based buffer overflow in the ExponentialFunction::ExponentialFunction function in Poppler before 0.40.0 allows remote attackers to cause a denial of service (memory corruption and crash) or possibly execute arbitrary code via an invalid blend mode in the ExtGState dictionary in a crafted PDF document.

Priority

Medium

CVSS 3 base score: 7.8

Status

Package Release Status
poppler
Launchpad, Ubuntu, Debian
Upstream
Released (0.40)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.41.0-0ubuntu1)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.24.5-2ubuntu4.4])
Patches:
Upstream: https://cgit.freedesktop.org/poppler/poppler/commit/?id=b3425dd3261679958cd56c0f71995c15d2124433