CVE-2015-8393

Published: 01 December 2015

pcregrep in PCRE before 8.38 mishandles the -q option for binary files, which might allow remote attackers to obtain sensitive information via a crafted file, as demonstrated by a CGI script that sends stdout data to a client.

Priority

Low

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (8.38)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:8.31-2ubuntu2.2)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1586