CVE-2015-8392

Published: 01 December 2015

PCRE before 8.38 mishandles certain instances of the (?| substring, which allows remote attackers to cause a denial of service (unintended recursion and buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror, a related issue to CVE-2015-8384 and CVE-2015-8395.

Priority

Low

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (8.38)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1585

Notes

AuthorNote
tyhicks
Issue affects PCRE3 only
Marking 'low' since it requires PCRE to operate on untrusted regular
expressions which is not very likely
mdeslaur
introduced in 8.34

0001-Fix-buffer-overflow-for-named-references-in-situatio.patch
in jessie

References

Bugs