CVE-2015-8388

Published: 01 December 2015

PCRE before 8.38 mishandles the /(?=di(?<=(?1))|(?=(.))))/ pattern and related patterns with an unmatched closing parenthesis, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Priority

Low

Status

Package Release Status
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (2:8.35-7)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:8.31-2ubuntu2.1)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1571

Notes

AuthorNote
tyhicks
Issue affects PCRE3 only
Marking 'low' since it requires PCRE to operate on untrusted regular
expressions which is not very likely
Fix for CVE-2015-5073 also fixes this issue
mdeslaur
was supposed to be fixed in wily (2:8.35-7ubuntu2) but got
reverted in (2:8.35-7ubuntu5) by mistake

CVE-2015-2325_CVE-2015-2326_CVE-2015-3210_CVE-2015-5073.patch
in jessie

References

Bugs