Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2015-7579

Published: 16 February 2016

Cross-site scripting (XSS) vulnerability in the rails-html-sanitizer gem 1.0.2 for Ruby on Rails 4.2.x and 5.x allows remote attackers to inject arbitrary web script or HTML via an HTML entity that is mishandled by the Rails::Html::FullSanitizer class.

Priority

Medium

Cvss 3 Severity Score

6.1

Score breakdown

Status

Package Release Status
ruby-rails-html-sanitizer
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(1.0.3-2)
cosmic Not vulnerable
(1.0.3-2)
precise Does not exist

trusty Does not exist

upstream
Released (1.0.3)
vivid Does not exist

wily Ignored
(end of life)
xenial Not vulnerable
(1.0.3-2)
yakkety Ignored
(end of life)
zesty Ignored
(end of life)
Patches:
upstream: https://marc.info/?l=oss-security&m=145375059928688&w=2

Severity score breakdown

Parameter Value
Base score 6.1
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Changed
Confidentiality Low
Integrity impact Low
Availability impact None
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N