Your submission was sent successfully! Close

CVE-2015-7331

Published: 30 January 2017

The mcollective-puppet-agent plugin before 1.11.1 for Puppet allows remote attackers to execute arbitrary code via vectors involving the --server argument.

Priority

Medium

CVSS 3 base score: 6.6

Status

Package Release Status
puppet
Launchpad, Ubuntu, Debian
Upstream
Released (2016.2.1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(enterprise only)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(enterprise only)