CVE-2015-6764

Published: 06 December 2015

The BasicJsonStringifier::SerializeJSArray function in json-stringifier.h in the JSON stringifier in Google V8, as used in Google Chrome before 47.0.2526.73, improperly loads array elements, which allows remote attackers to cause a denial of service (out-of-bounds memory access) or possibly have unspecified other impact via crafted JavaScript code.

Priority

Low

Status

Package Release Status
libv8
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

libv8-3.14
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Ignored
(libv8 not supported)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(libv8 not supported)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was ignored [libv8 not supported])
nodejs
Launchpad, Ubuntu, Debian
Upstream
Released (4.2.3~dfsg-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(8.10.0~dfsg-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(4.2.6~dfsg-1ubuntu4.1)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(code not present)