CVE-2015-6730

Published: 01 September 2015

Cross-site scripting (XSS) vulnerability in thumb.php in MediaWiki before 1.23.10, 1.24.x before 1.24.3, and 1.25.x before 1.25.2 allows remote attackers to inject arbitrary web script or HTML via the f parameter, which is not properly handled in an error page, related to "ForeignAPI images."

Priority

Medium

Status

Package Release Status
mediawiki
Launchpad, Ubuntu, Debian
Upstream
Released (1:1.25.5-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(1:1.27.4-1)
Ubuntu 16.04 LTS (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)
Patches:
Upstream: https://phab.wmfusercontent.org/file/data/zm24swymokh5ac5bqsms/PHID-FILE-n2jrbxtlmei74wxmvbsa/T97391.patch