CVE-2015-5726

Published: 13 May 2016

The BER decoder in Botan 0.10.x before 1.10.10 and 1.11.x before 1.11.19 allows remote attackers to cause a denial of service (application crash) via an empty BIT STRING in ASN.1 data.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
botan1.10
Launchpad, Ubuntu, Debian
Upstream
Released (1.10.10-1)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [1.10.5-1+deb7u1ubuntu0.14.04.1])

Notes

AuthorNote
seth-arnold
"Fixed in 1.11.19 and 1.10.10, affected all previous versions
of 1.10 and 1.11"

References