Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2015-5470

Published: 2 November 2015

The label decompression functionality in PowerDNS Recursor before 3.6.4 and 3.7.x before 3.7.3 and Authoritative (Auth) Server before 3.3.3 and 3.4.x before 3.4.5 allows remote attackers to cause a denial of service (CPU consumption or crash) via a request with a long name that refers to itself. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-1868.

Notes

AuthorNote
mdeslaur
incomplete fix for CVE-2015-1868
only affected pdns 3.2+ and pdns-recursor 3.5+

Priority

Low

Status

Package Release Status
pdns
Launchpad, Ubuntu, Debian
artful Not vulnerable
(3.4.5-1)
bionic Not vulnerable
(3.4.5-1)
cosmic Not vulnerable
(3.4.5-1)
disco Not vulnerable
(3.4.5-1)
precise Not vulnerable
(3.0-1.1ubuntu1)
trusty Does not exist
(trusty was needed)
upstream
Released (3.4.5-1)
utopic Ignored
(end of life)
vivid Ignored
(end of life)
wily Not vulnerable
(3.4.5-1)
xenial Not vulnerable
(3.4.5-1)
yakkety Not vulnerable
(3.4.5-1)
zesty Not vulnerable
(3.4.5-1)
pdns-recursor
Launchpad, Ubuntu, Debian
artful Not vulnerable
(3.7.3-1)
bionic Not vulnerable
(3.7.3-1)
cosmic Not vulnerable
(3.7.3-1)
disco Not vulnerable
(3.7.3-1)
precise Not vulnerable
(3.3-2)
trusty
Released (3.5.3-1ubuntu0.1)
upstream
Released (3.7.3-1)
utopic Ignored
(end of life)
vivid
Released (3.6.2-2+deb8u2build0.15.04.1)
wily Not vulnerable
(3.7.3-1)
xenial Not vulnerable
(3.7.3-1)
yakkety Not vulnerable
(3.7.3-1)
zesty Not vulnerable
(3.7.3-1)