CVE-2015-5297

Published: 31 December 2015

An integer overflow issue has been reported in the general_composite_rect() function in pixman prior to version 0.32.8. An attacker could exploit this issue to cause an application using pixman to crash or, potentially, execute arbitrary code.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
pixman
Launchpad, Ubuntu, Debian
Upstream
Released (0.33.4-1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(0.34.0-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(0.33.6-1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.30.2-2ubuntu1.2)
Patches:
Upstream: https://cgit.freedesktop.org/pixman/commit/?id=f10b5449a8b22a26839c58a716b74d6b7a8bcb80 (bp)
Upstream: https://cgit.freedesktop.org/pixman/commit/?id=15aa37adeca79a22b393ff451e6d29f484c3b0ef (bp)
Upstream: https://cgit.freedesktop.org/pixman/commit/?id=8b49d4b6b460d0c9299bca4ccddd7cd00d8f8441
Upstream: https://cgit.freedesktop.org/pixman/commit/?id=23525b4ea5bc2dd67f8f65b90d023b6580ecbc36