CVE-2015-4143

Published: 01 June 2015

The EAP-pwd server and peer implementation in hostapd and wpa_supplicant 1.0 through 2.4 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via a crafted (1) Commit or (2) Confirm message payload.

Priority

Medium

Status

Package Release Status
hostapd
Launchpad, Ubuntu, Debian
Upstream Pending
(2.5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Not vulnerable
(code not present)
wpa
Launchpad, Ubuntu, Debian
Upstream Pending
(2.5)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1-0ubuntu1.3)
Ubuntu 12.04 ESM (Precise Pangolin) Does not exist

wpasupplicant
Launchpad, Ubuntu, Debian
Upstream Pending
(2.5)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

Ubuntu 12.04 ESM (Precise Pangolin) Not vulnerable
(code not present)