CVE-2015-3418

Published: 13 December 2016

The ProcPutImage function in dix/dispatch.c in X.Org Server (aka xserver and xorg-server) before 1.16.4 allows attackers to cause a denial of service (divide-by-zero and crash) via a zero-height PutImage request.

Priority

Medium

CVSS 3 base score: 7.5

Status

Package Release Status
xorg-server
Launchpad, Ubuntu, Debian
Upstream
Released (2:1.12.4-6+deb7u6)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2:1.15.1-0ubuntu2.4)
Patches:
Upstream: http://cgit.freedesktop.org/xorg/xserver/commit/?id=dc777c346d5d452a53b13b917c45f6a1bad2f20b
xorg-server-lts-quantal
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

xorg-server-lts-raring
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

xorg-server-lts-saucy
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

xorg-server-lts-trusty
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

xorg-server-lts-utopic
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [2:1.16.0-1ubuntu1.2~trusty2])

Notes

AuthorNote
tyhicks
Introduced by the fix for CVE-2014-8092
mdeslaur
included by 0038-CVE-2014-8092-dix-allow-zero-height-putimage-requests.patch
in https://usn.ubuntu.com/usn/usn-2436-1

References

Bugs