CVE-2015-3228

Published: 24 July 2015

Integer overflow in the gs_heap_alloc_bytes function in base/gsmalloc.c in Ghostscript 9.15 and earlier allows remote attackers to cause a denial of service (crash) via a crafted Postscript (ps) file, as demonstrated by using the ps2pdf command, which triggers an out-of-bounds read or write.

Priority

Medium

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
Upstream Needed

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [9.10~dfsg-0ubuntu10.4])
Patches:
Upstream: http://git.ghostscript.com/?p=ghostpdl.git;a=commitdiff;h=0c0b0859