CVE-2015-2696

Published: 08 November 2015

lib/gssapi/krb5/iakerb.c in MIT Kerberos 5 (aka krb5) before 1.14 relies on an inappropriate context handle, which allows remote attackers to cause a denial of service (incorrect pointer read and process crash) via a crafted IAKERB packet that is mishandled during a gss_inquire_context call.

Priority

Medium

Status

Package Release Status
krb5
Launchpad, Ubuntu, Debian
Upstream
Released (1.13.2+dfsg-3)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(1.13.2+dfsg-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.12+dfsg-2ubuntu5.2)
Patches:
Upstream: https://github.com/krb5/krb5/commit/e04f0283516e80d2f93366e0d479d13c9b5c8c2a
Upstream: https://github.com/krb5/krb5/commit/a705b1160ce7f0c5f23b9859c4c6c707503fbfdc (tests)
Upstream: https://github.com/krb5/krb5/commit/92d6dd045dfc06cc03d20b327a6ee7a71e6bc24d (comments)