CVE-2015-2328

Published: 01 December 2015

PCRE before 8.36 mishandles the /((?(R)a|(?1)))+/ pattern and related patterns with certain recursion, which allows remote attackers to cause a denial of service (segmentation fault) or possibly have unspecified other impact via a crafted regular expression, as demonstrated by a JavaScript RegExp object encountered by Konqueror.

Priority

Low

Status

Package Release Status
mongodb
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(uses system pcre)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses system pcre)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(uses system pcre)
pcre2
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pcre3
Launchpad, Ubuntu, Debian
Upstream
Released (2:8.35-8)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2:8.38-3)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1:8.31-2ubuntu2.2)
Patches:
Upstream: http://vcs.pcre.org/pcre?view=revision&revision=1498

Notes

AuthorNote
sbeattie
since 2.0.0, mongodb packages use system pcre
tyhicks
Issue affects PCRE3 only
Marking 'low' since it requires PCRE to operate on untrusted regular
expressions which is not very likely
mdeslaur
0001-Fix-compile-time-loop-for-recursive-reference-within.patch
in jessie

References

Bugs