Your submission was sent successfully! Close

CVE-2015-2042

Published: 23 February 2015

net/rds/sysctl.c in the Linux kernel before 3.19 uses an incorrect data type in a sysctl table, which allows local users to obtain potentially sensitive information from kernel memory or possibly have unspecified other impact by accessing a sysctl entry.

From the Ubuntu security team

An information leak was discovered in how the Linux kernel handles setting the Reliable Datagram Sockets (RDS) settings. A local user could exploit this flaw to read data from other sysctl settings.

Priority

Low

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-armadaxp
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-aws
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-ec2
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-flo
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-fsl-imx51
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-gke
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-goldfish
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-grouper
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-hwe
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-hwe-edge
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-linaro-omap
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-linaro-shared
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-linaro-vexpress
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-quantal
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-raring
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-saucy
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-trusty
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-utopic
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-vivid
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-wily
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-lts-xenial
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-maguro
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-mako
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-manta
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-mvl-dove
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-qcm-msm
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-raspi2
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-snapdragon
Launchpad, Ubuntu, Debian
upstream
Released (3.19)
linux-ti-omap4
Launchpad, Ubuntu, Debian
upstream
Released (3.19)

Notes

AuthorNote
jdstrand
android kernels (flo, goldfish, grouper, maguro, mako and manta) are
not supported on the Ubuntu Touch 14.10 and earlier preview kernels
linux-lts-saucy no longer receives official support
linux-lts-quantal no longer receives official support
sbeattie
introduced in https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=3e5048495c8569bfdd552750e0315973c61e7c93

References

Bugs