CVE-2015-1832

Published: 03 October 2016

XML external entity (XXE) vulnerability in the SqlXmlUtil code in Apache Derby before 10.12.1.1, when a Java Security Manager is not in place, allows context-dependent attackers to read arbitrary files or cause a denial of service (resource consumption) via vectors involving XmlVTI and the XML datatype.

Priority

Medium

CVSS 3 base score: 9.1

Status

Package Release Status
derby
Launchpad, Ubuntu, Debian
Upstream
Released (10.13.1.1-1)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(10.14.1.0-1ubuntu1)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(10.14.1.0-1ubuntu1)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(10.14.1.0-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(10.14.1.0-1ubuntu1)
Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needed)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)