Your submission was sent successfully! Close

CVE-2015-1790

Published: 11 June 2015

The PKCS7_dataDecodefunction in crypto/pkcs7/pk7_doit.c in OpenSSL before 0.9.8zg, 1.0.0 before 1.0.0s, 1.0.1 before 1.0.1n, and 1.0.2 before 1.0.2b allows remote attackers to cause a denial of service (NULL pointer dereference and application crash) via a PKCS#7 blob that uses ASN.1 encoding and lacks inner EncryptedContent data.

Priority

Medium

Status

Package Release Status
openssl
Launchpad, Ubuntu, Debian
artful
Released (1.0.2c-1ubuntu1)
bionic
Released (1.0.2c-1ubuntu1)
cosmic
Released (1.0.2c-1ubuntu1)
disco
Released (1.0.2c-1ubuntu1)
precise
Released (1.0.1-4ubuntu5.31)
trusty
Released (1.0.1f-1ubuntu2.15)
upstream Needs triage

utopic
Released (1.0.1f-1ubuntu9.8)
vivid
Released (1.0.1f-1ubuntu11.4)
wily
Released (1.0.2c-1ubuntu1)
xenial
Released (1.0.2c-1ubuntu1)
yakkety
Released (1.0.2c-1ubuntu1)
zesty
Released (1.0.2c-1ubuntu1)
openssl098
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

precise Does not exist
(precise was needed)
trusty Does not exist
(trusty was needed)
upstream Needs triage

utopic Ignored
(reached end-of-life)
vivid Ignored
(reached end-of-life)
wily Does not exist

xenial Does not exist

yakkety Does not exist

zesty Does not exist