CVE-2015-0852

Published: 29 September 2015

Multiple integer underflows in PluginPCX.cpp in FreeImage 3.17.0 and earlier allow remote attackers to cause a denial of service (heap memory corruption) via vectors related to the height and width of a window.

From the Ubuntu security team

It was discovered that FreeImage incorrectly handled certain PCX files. An attacker could possibly use this issue to cause a denial of service.

Priority

Medium

Status

Package Release Status
freeimage
Launchpad, Ubuntu, Debian
Upstream
Released (3.15.4-4.2)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(3.15.4-4.2)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(3.15.4-4.2)
Ubuntu 20.10 (Groovy Gorilla) Not vulnerable
(3.15.4-4.2)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(3.15.4-4.2)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.15.4-4.2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.15.4-4.2)
Ubuntu 14.04 ESM (Trusty Tahr) Needed