Your submission was sent successfully! Close

CVE-2015-0209

Published: 17 March 2015

Use-after-free vulnerability in the d2i_ECPrivateKey function in crypto/ec/ec_asn1.c in OpenSSL before 0.9.8zf, 1.0.0 before 1.0.0r, 1.0.1 before 1.0.1m, and 1.0.2 before 1.0.2a might allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly have unspecified other impact via a malformed Elliptic Curve (EC) private-key file that is improperly handled during import.

Priority

Low

Status

Package Release Status
openssl
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver)
Released (1.0.1f-1ubuntu11)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (1.0.1f-1ubuntu11)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (1.0.1f-1ubuntu2.11)
Patches:
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=9e442d485008046933cdc7da65080f436a4af089 (trunk)
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=89117535f1bb3ea72a17933b703271587d7aaf0b (1.0.1)
Upstream: https://git.openssl.org/?p=openssl.git;a=commit;h=1b4a8df38fc9ab3c089ca5765075ee53ec5bd66a (0.9.8)
openssl098
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needed)