CVE-2014-9709

Published: 30 March 2015

The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Priority

Low

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
Upstream
Released (2.1.0-5)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(2.1.0-5)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (2.1.0-3ubuntu0.1)
Patches:
Upstream: https://bitbucket.org/libgd/gd-libgd/commits/47eb44b2e90ca88a08dca9f9a1aa9041e9587f43
Upstream: https://bitbucket.org/libgd/gd-libgd/commits/81e9a993f2893d651d225646378e3fd1b7465467
php5
Launchpad, Ubuntu, Debian
Upstream
Released (5.6.5+dfsg-1)
Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable

Patches:
Upstream: http://git.php.net/?p=php-src.git;a=commitdiff;h=07b5896a1389c3e865cbd2fb353806b2cefe4f5c
Upstream: http://git.php.net/?p=php-src.git;a=commitdiff;h=5fc2fede9c7c963c950d8b96dcc0f7af88b4d695